Butler ausfall! geht von online in den Standalone mode -> nicht Pingbar

e:cue Forum Foren Deutsche Diskussionsforen e:cue Hardware (D) Butler ausfall! geht von online in den Standalone mode -> nicht Pingbar

Ansicht von 9 Antwort-Themen
  • Autor
    Beiträge
    • #218710
      djmanu
      Teilnehmer

      hy,

      Habe das Phänomenon bei mehreren Kunden, dass die Butler nach einiger Zeit betrieb vom online mode in den Standalone mode fallen!
      wenn die Butler dann im Standalone mode sind hilft kein Driverrestart.
      Die Butler sind dann auch nicht mehr Pingbar!
      es hilft nur ein aus/einstecken der Stromzufuhr des Butlers!

      Der erste Verdacht war dass die Butler mit der Wärme nicht zurecht kommen.
      Das wars leider nicht! selbst bei konstanten 24°C fielen diese Butler immer wieder aus.

      Die zweite Vermutung war dass die Butler mit UDP Broadcasts anderer Geräte nicht zurechtkommen.
      Hatten in einer Disco mit 15mbit konstantem UDP Broadcast zu kämpfen…
      nur das wars auch nicht! Denn in einem Restaurant hängen die Butler direkt am EcuePC und die Butler fielen in den Standalone mode!

      Das geht natürlich in einer Disco, Restaurant oder Saal überhaupt nicht!

      Passiert bei S1 sowie S2!

      Bei einer Installation in einem Saal mit 1400 16bit Leuchten hab ich 2 LCE2 mit 5 ButlerXT2 und 2 Moxa verwendet (Active/Backup LCE) 10 sec timeout
      Da hatte das Problem dass die butler im Status init hängen geblieben sind! (das enet war vom restlichen Netzwerk sauber getrennt)
      ein command DriverRestart hat geholfen. Das kann ich aber nicht immer machen denn das Saallicht soll autonom funktionieren ohne mich!

      Bitte dringend um Hilfe für das Butler online/standalone problem und des init problems der XT2

      Verwende überall die neueste 7er Version!

    • #224303
      jensfreihoefer
      Teilnehmer

      Hallo Manuel,
      also das klingt natürlich sehr seltsam zunächst. Von solch einem Phänomen höre ich gerade zum ersten Mal.
      Bzgl. der Init Probleme:
      Hierbei handelst es sich um den Standalone Modus in der 2.ten Generation der Butler, also S2 und XT2.
      Für den Standalone Modus müssen hier mindestens ein Trigger gesetzt werden in der Trigger Engine, z.B. mit On Intialization > Action cuelist 1 Play. Damit bleiben die Geräte, sobald diese in den Standalone Modus gehen, nicht “hängen” sondern fahren eben die gewünschte Cueliste ab.
      Bzgl. dem Ausfall der Verbindung: hier wirds jetzt spannend. Um ein mögliches Problem finden zu können,
      brauchen wir möglichst viele Details der Installation. wir haben hundertes Systeme da draussen mit permanenter Netzwerkverbindung und einem ähnlichen Setup (soweit ich das sehen kann) und diese laufen problemlos 24/7 seit Jahren.
      Also, hierzu einige Fragen:
      – ist eine WLan Netzwerkverbindung im Spiel?
      – Gibt es ein dediziertes Netzwerk oder sind noch weitere Systeme auf dem selben Netzwerk?
      – Hast Du alle Energiesparmodi auf den Rechnern deaktiviert? Klingt für mich nach einer Netzwerkkarte, die im Standby des Rechners abgeschaltet wird.
      – Laufen die Rechner permanent durch oder werden diese in einen standby Modus gefahren? (Passwortschutz etc?)
      – UDP Broadcasts von anderen Systemen sind natürlich ungünstig und können definitv die Kommunikation des e:cue Systems behindern.

      Jegliche Details kannst Du natürlich auch gerne per Mail schicken an j.freihoefer[ääät]ecue.de , damit Du hier nicht Dein komplettes Projekt offen legen musst. Jegliche Infos behandeln wir selbstverständlich vertraulich.

      Beste Grüße und Danke,
      Jens

    • #224304
      djmanu
      Teilnehmer

      da wird ein makro getriggert

      Habe mehrere installationen bei denen es funktioniert!

      NEIN

      Im Restaurant JA, in der Disco NEIN

      Ja ist immer deaktiviert. Der fehler ist in der Disco nach 5 min aufgetreten und manchmal erst nach stunden. Das Restaurant läuft 24/7

      Restaurant 27/7, Disco nur am Wochenende, Saal 27/7

      Im Restaurant ist der Butler direkt mit dem Ecue rechner verbunden. Am Rechner läuft nur Ecue.

    • #224309
      bkruse
      Teilnehmer

      Hallo,

      dann würde ich mich auf das Restaurant konzentrieren, hier scheinen mir am wenigsten “äußerliche” Einflüsse/Störfaktoren vorhanden zu sein. Kannst du hier vielleicht noch mal das Setup ergänzen?
      Programmer V7.0 ist klar.
      Dediziertes Netzwerk habe ich auch heraus gelesen.
      Welche Butler/Firmware?
      Betrifft es alle Butler? (oder z.B. nur S2, aber nicht XT2?)

      Wie genau äußert sich Phänomen? Bisher habe ich heraus gelesen:
      – Butler gehen ohne Grund in den Standalone modus
      Frage: Was zeigt in diesem Fall das Display der Butler an?
      – die Butler sind nicht mehr ping-bar
      Frage: Wie Verhalten sich die Link/Act LEDs des Butlers? (die kleine grüne bzw. orange LED am e:net Port)
      Frage: der Webserver des Butlers (S2, XT2) ist auch nicht mehr erreichbar? Also http://192.168.123.1 im Browser aufrufen.

      Klingt jetzt so als würde das Verhalten nur in der Disco auftreten, im Restaurant aber nicht?

      Hierzu noch ein Kommentar:

      da wird ein makro getriggert[/quote]
      Also Call Macro können die Butler im Standalone mode natürlich nicht. Daher werden sie bei dieser Trigger Rule auch nichts tun. Sprich ein “Initialization” Trigger mit z.B. Cuelist Play oder Trigger Label muss her. Siehe auch die folgenden Blog posts (ich denke aber das meiste kennst du bereits):

      [list]
      [*] How to simulate the old Butler play mode
      [*] Defining triggers for Butler XT2 standalone
      [*] Show export: Dos and Don’ts
      [/list]

      Danke für deine Hilfe,
      Björn

    • #224310
      djmanu
      Teilnehmer

      Nur S1

      P01

      link ist aktiv aber die ip kann man nicht pingen… also auch keine Webseite (gibts glaub ich nur beim S2)

      Das war mir klar dass die XT2 keine Scripte verstehen.. die XT2 im Saal sollen “on init” auch nichts machen außer online gehen und nicht im init hängen bleiben! nur wenn ein Signal am Eingang 1 oder 2 kommt (brand und Notstrom) soll ein trigger ausgeführt werden (2 cuelists)
      siehe showfile das ich an jens geschickt habe.

      Den Butler S1 von der Disco kann ich euch mal schicken wenn ihr wollt, da ich bei mir einen auf Reserve hätte.
      In der Disco hängen am Butler nur Pulsar DMX Splitter…

    • #224311
      djmanu
      Teilnehmer

      any news?

      lg manuel

    • #224312
      marcoboy
      Teilnehmer

      Das der Butler nicht erreichbar ist deutet auf ein Netzwerkfehler hin.

      -Firewall die UDP Pakete verzögert oder blockiert ewt. Switch
      -DHCP oder feste IP?
      -mehre Netzwerkarten ?

      Was sagt das ARP Table ? Vielleicht bekommt einer der beiden plötzlich durch z.Bsp DHCP eine andere Adresse.

      Da sich die Geräte ähnlich verhalten tippe ich auf den gleichen Konfigurationsfehler. Bei allen anderen Kunden laufen die Geräte problemlos.

      Was erzeugt UDP Broadcast von 15mbit/s ? Artnet ? Ich würde sagen das muss nicht sein. Je nach Switch Konfiguration haben andere Pakete sowie so Vorrang. Es kann aber auch passieren das Broadcast Pakete in den Mülleimer wandern wenn der Spam ungewöhnliche Ausmaße annimmt.

      Man sollte Broadcast immer vermeiden. Im enet oder Artnet dient sie dazu Geräte im Netzwerk bekannt zu machen. Der Rest des Datenverkehrs sollte dann gezielt ablaufen.

      An den Broadcast Paketen erkennt der Programmer des die Geräte noch vorhanden sind und welchen Status zu haben. Die Pakete werden regelmäßig gesendet, was manche Hardware oder Firewallregel veranlasst sie zeitweilig zu blockieren.

      Sollte der Butler also selbständig in den standalone Mode wechseln sendet er seinen Status per broadcast . Dieser Status erscheint im Drive Status und im Info Fenster.

      Interessant ist was im Network Fenster steht ? Sucht er den Butler oder steht dieser standalone ? Der Programmer wird ihn wahrscheinlich suchen. Weil er keinen Broadcast Pakete mehr bekommt.

      Das abschalten des Butlers hat an der Netzwerkarte bzw. Hardware einen beiläufigen Effekt. Durch den Verlust des linkes wird die PHY zurückgesetzt auch die zuvor gesetzten Regeln. Was ich damit sagen will das durch das neu starten des Butler nicht unbedingt darauf zu schließen ist das hier das Problem besteht.

      Zur näheren Analyse kann man auch wireshark einsetzen.

    • #224313

      Hallo, Ich würde mich hier Marco anschließen, Wireshark wäre das Tool der Wahl.
      Alternativ muss man checken, wie die Switche sich verhalten,bzw gibt es noch weitere “intelligente” steuerungen á la Crestron? Je nach Konfiguration kann hier sehr hoher UDP Traffic aufkommen, bzw über dauerhafte Abfragen anderer Geräte, z.b. Temperatur etc.
      Bei Switchen ab Netgear Prosafe und hochwertiger gibt es auch im Switch eingebaute Tools, das Netzwerk zu überwachen.

    • #224345
      ZeroG981
      Teilnehmer

      Hallo zusammen.

      Ich muss sagen, ich kenne dieses Problem auch.
      Aktuell habe ich einen Butler (zugegeben einen älteren S1) in einer Festinstallation in einem Club. Er läuft ganz normal, plötzlich ist er aber offline. Was hilft ist: AEG (ausschalten, einschalten, geht). Nach ca. einer halben Stunde bis 4 Stunden tritt der Fehler erneut auf- ganz unregelmäßig.
      Ich habe den Butler jetzt gegen einen neuen XT2 getauscht. Jetzt läufts. Ein Problem mit dem Netzwerk ist´s also eher nicht.

      Ich kenne das Problem schon länger- ebenso in einem Club. Dort wurden die Butler zuerst über PoE betrieben, nach ca. einem Jahr war das Ding plötzlich nicht mehr erreichbar. Geholfen hat ein externes Netzteil, was seitdem den Butler mit Strom versorgt. Der oben genannte Butler läuft aufgrund dieser Erfahrung aber schon immer mit externem Netzteil.
      Ist schon etwas komisch.
      Nachdem meine Erfahrungen nicht zeigen, dass die Butler 100% stabil laufen, kann ich mir ehrlich gesagt nicht vorstellen, dass es in anderen Anwendungen nicht auch Probleme gibt.

      Hatt noch jemand Probleme im Dauerbetrieb?

      Danke und Grüße

    • #224346
      bkruse
      Teilnehmer

      Hallo,

      zu viele broadcasts können die Butler in der Tat in die Knie zwingen. 15mBit wäre definitiv eine solche Menge.
      Bewegt man sich im Grenzbereich, könnte dies sporadisch auftreten.
      Tauscht man dann einen alten (Classic, XT) gegen einen neueren Butler (S2, XT2; welche etwas mehr Rechenleistung haben), könnte das Symptom verschwinden.
      Streaming server könnten auch das Netzwerk so stark nutzen/belasten, das die e:cue Pakete in dem Traffic unter gehen.

      Nicht ohne Grund fordern wir daher eine separates Netzwerk für die e:cue Geräte untereinander.

      Es wurden schon die richtigen Analysewege gezeigt, z.B. IP Adressen/arp table prüfen oder andere Steuersysteme einmal (temporär) deaktivieren. Wireshark zeigt idR gut, welche Systeme welche Art von Traffic verursachen.

      Da nahezu alle Installationen dieses Problem nicht aufweisen (inkl. keines der 200+ Geräte in unserem Langzeittest), gehen wir davon aus das dieses Problem auf die jeweilige Installation bzw. deren Netzwerk-Setup zurückzuführen ist. Wir unterstützen natürlich gern und sind ebenfalls an potentiellen Inkompatibilitäten interessiert.
      Wie gesagt, bekannt ist ja bereits das eine zu große Anzahl broadcast Pakete genau solch ein Verhalten verursachen kann.

      Ich hoffe das hilft,
      viele Grüße,
      Björn

Ansicht von 9 Antwort-Themen
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.