HASP Driver

Ansicht von 3 Antwort-Themen
  • Autor
    Beiträge
    • #247563
      Jon Rose
      Teilnehmer

      Hi, I am trying to get the HASP driver working on a Windows 11 machine. I found the post about it with the link to the sentinel run time installer, which I have installed, but programmer keeps coming up with the error 1009 cannot open the HASP drivers. Tried uninstalling, and re-installing with no results. I can see the USB dongle in device manager (there are 3 devices, the HASP key, the HL key and the USB key).

      Any suggestions to how to get it working?

    • #247565
      Christoph Paduch
      Moderator

      Hello Jon

      We have a more detailled description, how to install the drivers here: https://support.ecue.com/help
      search for “hasp” and select the Error1009 article.

      I hope, this will help.


      Kind regards / Freundliche Grüße
      Christoph Paduch

    • #247566
      Jon Rose
      Teilnehmer

      I have just tried that (about 3 times) and still having the same issue.

      If i check the installation using the haspdinst.exe -info I can see it has all installed correctly apart from the akspccard.sys and the aksfridge.sys which show as not loaded. Is this correct?

      • #247567
        Christoph Paduch
        Moderator

        Hello Jon

        It is corrrect, that these both files are not loaded.
        But unfortunately the actual driver 8.43 does not work on my machine either.
        I try to contact the Thales support.
        I will update you and the KB article, in case of a solution.


        Kind regards / Freundliche Grüße
        Christoph Paduch

      • #247568
        Christoph Paduch
        Moderator

        Hello Jon

        Please read our KB article: https://support.ecue.com/help/en-gb/11/80

        There is also driver V8.31 attached, which will work.

        I hope, this will help.


        Kind regards / Freundliche Grüße
        Christoph Paduch

    • #247585
      Tue Selmer Friborg
      Teilnehmer

      The KB article is very well written.
      When I execute line 9: “Install with haspdinst.exe -i -ld (with legacy drivers)” I get an error stating:
      “Sentinel Run-time Environment Installer v.8.43
      Unable to start service.
      This is an internal error. For assistance, contact your administrator or the software manufacturer
      Status Code: 30 5 929 1275”

      After this only “hlvdd.dll” and “hasplmv.exe” has been installed.

      I am using Windows 11 Pro version 22H2 on a Mac M1 using parallels.
      Could the ARM processor be the reason for this not working? And if so: Is there a solution on the way?

      • #247588
        Christoph Paduch
        Moderator

        Hello Tue
        Please install first with driver V8.31 that is linked to the article. Do not use the actual driver for the first part of the installation in step (9). The actual driver does not contain legacy drivers, so option -ld does not work here. But in fact we need exactly those legacy drivers. So in step (15) we install the actual driver, but here with option -i only.

        The article has been updated in September.


        Kind regards / Freundliche Grüße
        Christoph Paduch

Ansicht von 3 Antwort-Themen
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.